[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:00235] Re: X失敗


丸山@分子研です。普段はRedHat5.2+PJE0.3alphaを使っています。
Vineは1.0betaを試そうと思っています(^^;

/etc/X11/Xは通常/usr/X11R6/binの下にあるビデオカードに
対応したサーバーにリンクが張られます。どちらにしろ、
Xの設定に失敗されているようです。

/usr/X11R6/bin/にお使いのビデオカード用のXサーバーが
ないようでしたらそれをrpmしてみてください。それから
XF86Setup
で再度Xを設定するのがよろしいでしょう。

> ぱおねこです。
>  LinuxJapan3月号のVine Linux Ver.0.9β7 をインストールし、先程MLに入会し
> ました。
>  早速で恐縮なのですが、Xがうまくいきません。
>  全く同様の症状がfj.os.linuxにも投稿されているようですが、startxすると、
> 以下のメッセージが表示されます。
> 
> execve failed for /etc/X11/X (errno 2)
> _X11TransSocketUNIXConnect: Can't connect: errno = 2
> _X11TransSocketUNIXConnect: Can't connect: errno = 2
> _X11TransSocketUNIXConnect: Can't connect: errno = 2
> _X11TransSocketUNIXConnect: Can't connect: errno = 2
> _X11TransSocketUNIXConnect: Can't connect: errno = 2
> _X11TransSocketUNIXConnect: Can't connect: errno = 2
> giving up.
> xinit:  No such file or directory (errno 2):  unable to connect to X
> server
> xinit:  No such process (errno 3):  Server error.
> 
>  ところで、/etc/X11/ には、Xは無いようです。
>  /usr/X11R6/bin/X にシンボリックリンクを張ってみましたが、こんどは、
> 
> _X11TransSocketUNIXConnect: Can't connect: errno = 2
> 
>  が、Ctrl-Cするまで延々と出力されます。
>  それから、/usr/X11R6/lib/X11/XF86Config のリンク先である、
>  ../../../../etc/X11/XF86Config
>  は存在しませんでした。これはルートから辿っていくと/etc/X11/ですが、
> XF86Configがないので、
>  /usr/X11R6/lib/X11/XF86Config.eg を名前を変えてコピーしてみました。 
> 
>  インストール時には、ビデオカードの自動検出もうまくいっていた様なのです
> が、何か、根本的にインストールに失敗しているような気がします。
>  どんな原因が考えられるでしょうか? また、たまたま私と、fj.os.linuxに投
> 稿されていた方だけなのでしょうか?
> 
> -- 
>  **************************
>  *  paoneko@e-game.co.jp  *
>  *       Thank you!       *
>  **************************

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: References: