[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:00644] Re:日本語でgnome を使うにはRe: install finished )


武井@Project Vineです.

From: Yoshitaka Ozawa <yozawa@rd.tokodenki.co.jp>
Subject: [vine-users:00637] Re: 日本語で gnome  を使うには  Re: install finished )

> 小沢@東光電気です。
> 
> <19990207210910L.takei@hh.iij4u.or.jp>の記事において
> takei@hh.iij4u.or.jpさんは書きました:
> > 武井@Project Vineです.
> > 
> > gnomeの0.30以降(具体的には忘れた)って gtk+ が 1.1以降でなければ いけませんよねぇ.
> > redhat 5.2でも gtk+が 1.0.xなので 0.20なはずです.
> redhat 5.2 では i386/gnome 以下に gnome のフルセットが
> 付属していて、これは 0.30 です。したがって、gtk+ も 1.1.x を
> 使うようになっています。

あ 勘違いしてました.前にチェックしたはずだったのに(笑


> > gimp,vmail 等が動かなくなる可能性ありますよ.
> > (て もう分かってますかね)
> この問題のため、上記のディレクトリには gtk+10,glib10 という
> パッケージ名で gtk+-1.0.x のライブラリ*のみ*がインストール
> されるようになっています。
> 
> # gtk-config 等は 1.1.x のものしかインストールされないので、
> # 1.0.x を前提としたプログラムはコンパイル出来ません。
> 

まぁ 1.1.x か 1.0.xのどちらかをsubにして,
両方makeできるようにするといいすかねぇ.


> > とりあえず ja.po と ja.gmoと gtkrc.jaな gnome-libs-0.20_jpわ
> > 準備してあります.
> 今の gnome は、1.1.7 以降(でしたっけ?)のマルチバイトの扱いに
> 問題のない gtk+ を使用すれば、日本語の表示もパッチなどを当てる
> 必要もありません。

はい.gnome-linuxconfを優先で考えて,いましたので,それで 0.20を選んで
います.上の0.20も ja.po ja.gmo gtkrc.ja以外は元とかわってません.
日本語locale メッセージを入れただけみたいなもんです.

> 
> # 実際に殆んどのものに ja.po 等もついています。
> 
> gtk+10,glib10 パッケージがインストールしてあれば、gimp-1.0.2
> 等も問題無く動きます(もちろん日本語化は必要です)ので、Vtools も
> 1.1.x 環境へ移行した方が良いのではないでしょうか?

これは,悩みどころです.
1.2.xが出たら移るつもりのようです.

> 
> # gnome 1.0 は、gtk+1.1.x でないと動きませんから。:-)
> 
> 自宅に帰れば、日本語化したgtk+10,glib10 等の SPEC ファイル等も
> あるので、必要があれば提供できます。

両方make できるようにして(1.0.xを subにして)
VinePlusで いれてみてもいいかもしれませんね. 
 

では.

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
References: