[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:00684] Xconfigurator でcore/genelicSVGA800*600 の設定は?


きんねこ@金沢です。

  おそまきながら、0.9b7 を入れています。

BOARD: GIGABYTE GA-586HX (babyAT/Intel430HX/6-SIMM/4-PCI/4-ISA)
BIOS: AWARD PCI/PNP 586
CPU: Pentium166
MEM: 64MB (16M EDO SIMM *4) TAGRAM付(いまのところ意味ないけど)
HDD: Qantum Fireball SE 6.4G
VIDEO: MATROX MGA PCI2? (500-01 Rev.D 1993/chip MGA POWER GRAPHICS IS-ATLAS R1 9416KK722/2MB?)
NIC: NE2000コンパチISA (E2000/T/Cplus chip UMC UM9008F)
CD: MITSUMI CRMC-FX800S

  という構成で、ISA NIC でトラブりましたが、なんとかインストールは
 終わったようです。

  PC-UNIX は、もっぱらサーバー構築ばかりで、GUI で使った事がありま
 せんで、X の起動に失敗しております。

#startx
execve failed for /etc/X11/X (errno 2)
_X11TransSocketUNIXConnect: Can't connect: errno = 2
(くりかえし)
giving up.
xinit: No such file or directory (errno 2): unable to connect to X server
xinit: No such process (errno 3): Server error.

 こんな感じです。

  私の記憶が確かなら、/usr/X11R6/bin/X が普通だと思っていたのですが、
 Vine では違うようですね。RedHat もそうなのかな?

  素直に、Xconfigurator を起動して設定を行い、保存しようとすると、
 core 吐いて落ちてしまいます。rpm で Xconfigurator を入れ直してみて
 も結果はかわりません。

  こうなれば自力と、startx して出てくるエラーを順次 fix するように
 作業を行い、

ln -s /usr/X11R6/bin/XF86_SVGA /etc/X11/X

 してから、

cp /usr/X11R6/lib/X11/XF86Config.en /etc/X11/XF86Config

 して、XF86Config の書き換えをしています。fontpath のエラーを直し、
 SVGA Generic の VideoRam を 2048 に設定すると、画面はグチャグチャ
 ですが、起動はするようになりました。
 
  このぐちゃぐちゃ画面をマトモにしたいのです。

  ディスプレイは、NANAO FlexScan54T ですので、

HorizSync 24.5-86
VertRefresh 55-160

 です。

  ビデオカードは、おそらく

>Ultima (MGA-ULT/2/A, MGA-PCI/2, MGA-VLB/2) 2MB

 ではないかと思うのですが、単純に SVGA で 800*600 で表示するには、
 どのような XF86Config を書けばいいのでしょうか。

------------------------------------------------------------------
伊達 康司 <date@po.incl.ne.jp>

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: