[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:04704] X11amp


戸田裕一です。

ちょいネタですが、

x11ampの0.9以降の版はGTK1.2以上を要求してきます。

例えば、x11amp-0.9-beta1.1-1.i386.rpmをインストールしようとすると、

必須パッケージがインストールされてません:
        gtk+ >= 1.2.0 が x11amp-0.9-beta1.1-1 に必要です
        libgdk-1.2.so.0 が x11amp-0.9-beta1.1-1 に必要です
        libglib-1.2.so.0 が x11amp-0.9-beta1.1-1 に必要です
        libgmodule-1.2.so.0 が x11amp-0.9-beta1.1-1 に必要です
        libgtk-1.2.so.0 が x11amp-0.9-beta1.1-1 に必要です
        libaudiofile.so.0 が x11amp-0.9-beta1.1-1 に必要です
        libesd.so.0 が x11amp-0.9-beta1.1-1 に必要です

と言われます。

そこで、/Vmag5/15号についてきたgnomeパッケージの中から上記のライブラリを含む、
gtk+1.2.0-2
glib-1.2.0-1
audiofile-0.1.6-1
esound-0.2.8-2
の4つのrpmパッケージを入れると使えるようになりました。
その他のアプリケーションには影響ないようです。gimpもふつーに動きます。

ちなみに/Vmag5/15号のgnomeはVineと共存できる形になっているとあったので、
ftp等で手に入るgtkでうまく行くかどうかはわかりません…(^^;)

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」