[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:06424] Re: trouble to upgrade slang


吉田智彦です。

> http://kondara.sdri.co.jp/SRPMS/slang-1.3.5j063-0.src.rpm
> と、DOS/V Magazine 5月15日号の付録 CD-ROM の中に収録されていた
> slang-1.2.2_jp-4.src.rpm を、それぞれ rpm -i で展開し、
> slang-1.2.2_jp.spec をもとに、添付したような spec file を作成して
> パッケージを作成しようと試みてみました。

なぜ、slang-1.3.5j063-0.src.rpm からスペックをいじる必要があった
のか、ちょっと謎です。あ、パッケージ名称をきちんとしたかったのですね。

> rpm -bb まではうまくいくのですが、rpm -Uvh してみると、
> 
> slang-1.3.5_jp-1 はすでにインストールされています
> エラー: /home/yasuhide/rpm/RPMS/i386/slang-1.3.5_jp-1.i386.rpm をインストールできません

この原因は SPEC ファイルの
> Requires: slang = 1.3.5_jp
だと思います。

> slang-1.3.5j063-0.src.rpm を何も考えずに入れると、
> lynx で掲示板への書き込む時に、日本語が文字化けしてしまうので、
> 出来れば一つのライブラリで lynx と mutt/slrn を
> うまく動作させたいと思っています。

全ての slang アプリを rebuild すればおそらく大丈夫でしょう。
ひょっとして、期待してる答えじゃなかったりしたらごめんなさい。

-----------------------------------------------------------
システムデザイン研究所  sdl@nurs.or.jp
                        http://www.sdri.co.jp/
                        03-3686-5323 / 090-2178-9001
Tomohiko Yoshida        kitcho@tk.xaxon.ne.jp
                        http://www.tk.xaxon.ne.jp/~kitcho/
-----------------------------------------------------------

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: References: