[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:06442] kernel2.2.xとppxp


富山と申します。
いつもメールの記事を参考にさせていただいております。
先日先人の方々のメール並びに松本様のMANUAL等を参考にKernelを
2.2.9にアップデートしました。

ほぼうまくいったと思ったのですが、今のところppxpだけが使えま
せん。松本様のマニュアルに従ってuserlinkはrebuildしたのですが。
エラーの内容からtclとtkxに問題がありそうですが、私には解りません。
もし、対処の仕方をご存じの方がいらっしゃいましたら、ご教示願え
ると幸いです。

エラーの内容は一般ユーザーの時とrootの時で異なります。

<一般ユーザー時>
[tomo@localhost tomo]$ tkppxp &
[1] 1083
[tomo@localhost tomo]$ error reading package index file /usr/lib/tclX8.0.3/pkgIndex.tcl: syntax error in expression "[info tclversion] < 8.0jp"
error reading package index file /usr/lib/tkX8.0.3/pkgIndex.tcl: syntax error in expression "[info tclversion] < 8.0jp"

ここまで。

<rootの時>

[root@localhost /root]# tkppxp &
[1] 351
[root@localhost /root]# Application initialization failed: no display name and no $DISPLAY environment variable
Error in startup script: invalid command name "bind"
    while executing
"bind Popup <ButtonPress> {
    set popup(button_press) 1
}"
    (file "/usr/lib/ppxp/tkppxp/scripts/popup.tcl" line 6)
    invoked from within
"source $file"
    ("foreach" body line 4)
    invoked from within
"foreach f $sources {
    set file [file join $SCRIPTDIR $f]
    if [file readable $file] {
        source $file
    }
}"
    (file "/usr/bin/tkppxp" line 36)
ここまで。
userlinkとppxpのバージョンは以下の通りです。
ppxp-0.98112523-7.src.rpm
userlink-0.98a-9.src.rpm
いつもtkppxpでダイアルアップしていたので使えなくなってしまいました
。従って本日はWINのメールからです。kernel-2.0.36の時のバックアップ
はあるので、どうしてもダメなら戻す手もありますが、後一歩という気が
してますし、2.2.9の方がGNOMEが安定しているし、動作も若干速く感じる
ので、何とか使っていきたいものです。
よろしくお願いいたします。

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: