[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:06568] kernel2.29とppxp(解決)


富山と申します。
先日掲題の件で投稿しましたが、これはFAQでした。ppxpのホームページ
にちゃんと書いてありました。
調査不足で申し訳ありません。
一応、まだ私のような人がいるといけないので、書きます。

kernel-2.2.x ではuserlinkのrebuildだけではなく、ppxpのバグの修正が
必要でした。実際には既に修正された最新版のsrc.rpmをダウンロードし
て来てrebuildしました。

1.ppxpとuserlinkを(userlinkは必要かどうか分りませんが、一応)ダウン
  ロードしました。)
  ppxp-0.99030108-3.src.rpm
  userlink-0.98a-9.2.i386.rpm
  の二つをhttp://kondara.sdri.co.jpから頂きました。

2.# rpm --rebuild userlink-0.98a-9.2.src.rpm
  # rpm --force -Uvh
/usr/src/redhat/RPMS/i386/userlink-0.98a-9.2.i386.rpm

3.# rpm --rebuild ppxp-0.99030108-3.src.rpm
  # rpm --force -Uvh
/usr/src/redhat/RPMS/i386/ppxp-0.99030108-3.i386.rpm
  # rpm --force -Uvh
/usr/src/redhat/RPMS/i386/xppxp-0.99030108-3.i386.rpm
  # rpm --force -Uvh
/usr/src/redhat/RPMS/i386/tkppxp-0.99030108-3.i386.rpm
  ここで以下のアラーム発生。
  「必須パッケージがインストールされてません:
        /usr/local/bin/wish が tkppxp-0.99030108-3 に必要です」

  調べると、当該のファイルがちゃんとあるので、
  # rpm --nodeps -Uvh
/usr/src/redhat/RPMS/i386/tkppxp-0.99030108-3.i386.rpm

以上で、tkppxpが使えるようになりました。
手順におかしい部分があるかも知れません。その際は御指摘頂けると勉強になり
ます。

-------------------------------
         富山 智彦
   t_tom@mvg.biglobe.ne.jp
-------------------------------

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」