[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:08258] Re: XEmacs configure error -> mew error



yusu> ここで、上記にようにvineにはpatchコマンドがなかったので、
yusu> これはできませんでした。(この影響かもしれない。)
これは私の発言です。やはり、疑わしきはこのことでした。
noteに入れたvineにはpatchコマンドが存在してました。
installミスの可能性大なので、全部入れ替えたら、ちゃんとpatchが
入ってました。0.9βから1.0にあげるときにおまかせinstallをしたためだと
思います。カスタムインストールで、format installで/usrをformat指定したら
うまくできたようです。installerも信用できません。
問題のxemacsの方もできました。(当初のエラーなく)

# tar zxvf xemacs-21.0.67.tar.gz
# tar zxvf xemacs-21.0.67-elc.tar.gz
# tar zxvf xemacs-21.0.67-info.tar.gz

./configure i386-unknown-linux --x-includes=/usr/X11R6 --with-xim=xlib --with-mule --with-xfs

次は、mewのコンパイルなのですが、(もう少し同じthreadでお付き合い下さい。)
makeで下記のようにこけます。どうすればいいのでしょうか。

[root@yusu mew-1.94b21]# make
Compiling EL files of Mew ... 
PLEASE IGNORE WARNINGS IF DISPLAYED. TAKE IT EASY!
xemacs -batch -q -no-site-file -l ./temp.el -f mew-compile
Symbol's function definition is void: setup-japanese-environment
xemacs exiting.
make: *** [all] Error 255
[root@yusu mew-1.94b21]# 

Makefileの中身なのですが、下記のようになってます。
/usr/local/lib/xemacs/ の下にsite-lispがないのでmkdirで作りましたが
結果は同じでした。(以下参考)
##
## A directory where mew*.el[c] will be installed.
##
ELISPDIR  = $(PREFIX)/lib/$(EMACS)/site-lisp
#ELISPDIR = $(PREFIX)/share/emacs/site-lisp
#ELISPDIR = $(PREFIX)/lib/emacs


下記のpakagesの中身はまだ何もしてません。
[root@yusu /root]# ls /home/ftp/pub/xemacs-21.0.67/packages
00_TRANS.TBL                        xemacs-sumo-1999-03-12.tar.gz
xemacs-mule-sumo-1999-03-12.tar.gz
[root@yusu /root]# 


kawabe> これ,僕に言っているのですか?
kawabe> 変な引用やめてくれますか.
kawabe> # 僕の XEmacs のバージョンは User-Agent 見れば分かる.
kawabe>    かかわるんじゃなかったぜ.
ちょっと間違えられたようです。気になさらないで下さい。

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: References: