[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:08663] Re: Kernel mkinitrd error.


かわべさん、ありがとうございます。

Tsuyoshi KAWABE wrote:
> 
> > が、最後の mkinitrd で以下のエラーが出ます。
> >
> > mount: the kernel does not recognize /dev/loop0 as a block device
> >        (maybe `insmod driver'?)
> > Can't get a loopback device
> >
> > config は大きいので見合わせましたが、必要でしたら次回添付します。
> 
> う〜ん,その見合わせた config の
> CONFIG_BLK_DEV_LOOP
> あたりとか関係ないでしょうか?
> --
> Powered by Vine 1.1 (Rheingau), Kernel 2.2.10 on an i686, VinePlus 0.1.1
> 私からのメールまたは私へのメールは日本国によって盗聴される可能性があります.

CONFIG_BLK_DEV の辺りを抜き出します。

#
# Block devices
#
CONFIG_BLK_DEV_FD=m
CONFIG_BLK_DEV_IDE=y

#
# Please see Documentation/ide.txt for help/info on IDE drives
#
# CONFIG_BLK_DEV_HD_IDE is not set
CONFIG_BLK_DEV_IDEDISK=y
# CONFIG_BLK_DEV_IDECD is not set
# CONFIG_BLK_DEV_IDETAPE is not set
# CONFIG_BLK_DEV_IDEFLOPPY is not set
# CONFIG_BLK_DEV_IDESCSI is not set
CONFIG_BLK_DEV_CMD640=y
# CONFIG_BLK_DEV_CMD640_ENHANCED is not set
CONFIG_BLK_DEV_RZ1000=y
CONFIG_BLK_DEV_IDEPCI=y
CONFIG_BLK_DEV_IDEDMA=y
# CONFIG_BLK_DEV_OFFBOARD is not set
CONFIG_IDEDMA_AUTO=y
# CONFIG_IDE_CHIPSETS is not set

#
# Additional Block Devices
#
# CONFIG_BLK_DEV_LOOP is not set
# CONFIG_BLK_DEV_NBD is not set
# CONFIG_BLK_DEV_MD is not set
# CONFIG_BLK_DEV_RAM is not set
# CONFIG_BLK_DEV_XD is not set
CONFIG_PARIDE_PARPORT=y
# CONFIG_PARIDE is not set
# CONFIG_BLK_DEV_HD is not set

言われている CONFIG_BLK_DEV_LOOP は N にしています。
その他の CONFIG_BLK_~ に引っかかっているんでしょうか。
IDE チップセットの辺りは良く分からないのでそのままです。
FD と IDE の部分は抜けませんよね。と、したらどこでしょう? 
この他の部分が係わって来るのでしょうか。

# SCSI の部分以外は、すんなり行くと思っていたのに・・・

####################################
Kaz Ishida.
E_Mail: ishidakz@mxa.nakansai.ne.jp
####################################

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
References: