[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:09589] VinePlus gnuplot の不具合か


いいじまと申します。

◆
先日、VinePlusのgnuplotをftpでダウンロードして使ってみました。
しかし、動作によくわからなかった点がありました。症状を改善する
ためになにかヒントをいただければと思っています。
どうかよろしくお願いします。


●1
まず、ちょっと気づいた点を先に書きます。それはgnuplotのヘルプが
gnuplotから見えていません。たぶん、makeするときのミスではないか
と思います。具体的には、gnuplotを起動した後、helpと打つと、

gnuplot> help
/usr/local/share/gnuplot.gih: No such file or directory

となります。rpm -ql gnuplotの結果は、
/usr/bin/gnuplot
/usr/bin/gnuplot_x11
/usr/man/man1/gnuplot.1
/usr/share/gnuplot.gih

なので、ま、そういうことだと思います。



●2
つぎに一般ユーザーでコンソールにてgnuplotを利用するときに
つまづいた点ついて、助言をいただけたらと思い書きます。

一般ユーザーでログインしたのち、Xを立ち上げずに、コンソール
のままでgnuplotと打って起動すると、
Terminal type set to 'unknown'

といわれます。そこで、terminalを設定しようとして
gnuplot> set terminal linux

と打つと、今度は
Terminal type set to 'linux'
         Linux terminal driver not available

と言われ、うまくターミナルを設定できません。
で、そのまま試しに、
gnuplot> plot x 

と打つと、
svgalib: Cannot get I/O permissions. というメッセージ
がでます。一般ユーザーで使用できるにはどのようにすれば
よいでしょうか。以上の操作はkonを立ち上げずに行なって
います。

一般ユーザーでは上記のとおりなのですが、rootでログイン
したのち、あるいはsuでrootになってから、gnuplotとタイプ
して起動すると、
 
Terminal type set to 'linux'

とうまく設定されて起動します。ただ、起動画面の文字の
上部に今度は一般ユーザーのときには表示されなかった
 
PCI bus error.  We only handle type 1 PCI bus at present.
This is type 0
Using VGA driver.

というメッセージが表示されます。rootで利用する場合には特に
問題なくplot x**2 などもコンソールできれいなカーブが表示さ
れます。

使用しているパソコンは、FMV-475NL/T(B5ノート:HDD340MB,
MEM:24MB,CPU:486-74Mhz)です。
カーネル最構築時のPCI bios support は n にしています。
			(yにするとエラーがメッセージがでるので)


///////////////////////////////////////////////////////////////////////
			  << IIJIMA Kenji >>
			wise@momo.so-net.ne.jp

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: