[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:030023] insmod agpgart failed on i815E & GeForce2 MX


ひらかわと申します。21 世紀が始まりましたね。

さて、この度 New Machine を買いまして Vine Linux 2.1 をインストールし
たのですが、X のインストールで思ったより派手にハマっています。よろしけ
ればご助言をお願いします。

<現象>
agpgart が insmod できない

シェルから手で insmod を起動し agpgart をロードしようとすると…

/lib/modules/2.2.17-0vl10/misc/agpgart.o: init_module: デバイスもしくはリソースがビジー状態です
Using /lib/modules/2.2.17-0vl10/misc/agpgart.o
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters

と言われてしまいます。最初は PCI スロットに差してるカード(特に Sound
Blaster Live!)がまずいのかと思い、PCI カードを全部外してみたのですが
状況は変わりません。過去ログを参考に I810Gtt を載せたり、conf.modules 
の char-major-10-175 も直したのですが、これでもうまくいきません。
Laser5 の XFree86 4.0.1 ももちろん拾ってきています。Windows98 を参考に
IO アドレスや IRQ を設定してもダメでした。ダメモトで Red Hat 7.0 も入
れてみたのですが、結果は同じです。

<環境>

 OS:  Vine Linux 2.1 FTP 版(Win98SE, Win2000Pro, WinNT4, Vine 
      Linux 2.1 のマルチ OS 環境。ブートセレクターは System 
      Commander 2000)
 M/B: ASUStek CUSL2 (i815E、オーディオ無し、内蔵ビデオは disabled)
 Video: GeForce2 MX 32M AGP
 Sound: Sound Blaster Live! Value
 SCSI:  Adaptec AHA2940AU
 Memory: SDRAM 256Mbytes CL=? * 1
 CPU: Intel Pentium III 800EB(定格動作)


AGP のビデオカードを扱うのは始めてで勝手がつかめません。ポインターだ
けでも結構ですので情報を頂けると助かります。よろしくお願いします。

# そもそも i815E + GeForce2 に XFree86 を載せるのが無謀なのかな?

-- 
平川 貴彦                        mailto:hirakawa@remus.dti.ne.jp
                                 http://www.remus.dti.ne.jp/~hirakawa/

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: