[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:030036] Re: postgresql-6.5.3_jpの質問


半角文字と全角文字の混ざっているのは気持ちが悪いのでやめてください。
とりあえず全て半角に直しておきましたが…。

On Mon, Jan 01, 2001 at 01:01:53PM +0900,
Yutaka Tamura <tamura@post.click.or.jp> wrote:
> 
> apache + postgresql + php をVine2.0で使おうと思っています。
> 最初にpostgresql-6.5.3をインストールしようと思っているのですが、
> 次のことが分かりません。

新規に入れるのなら、最近のバージョンでもいいような気がしますが…。
たぶん一般的な手順としては /usr/local/pgsql あたりに入れるので、アンイ
ンストールやアップグレードはそれほど困らないはず。

VineSeed の src.rpm を流用するのも悪くないかも…。
# むろん『自己責任で』ですが。

> AlpHa FACTORY(http://www.alpha.or.jp/Vine/VinePlus/RPMS/)から
> 
> postgresql-6.5.3_jp-2.i386.rpm
> 
> をダウンロードし、新規インストール後/etc/rc.d/init.d/postmaster start で
> そんなファイルはありません!と怒られます。
> 
> /etc/rc.d/init.d/にpostgresql やpostmasterを登録するには
> どうすれば良いんでしょう?

rpm で入れたのですから、

# /etc/rc.d/init.d/postgresql start

というコマンドを実行するとどうですか? また、

$ rpm -ql postgresql | fgrep /etc/rc.d/init.d/

で何か出てきませんか?

> それからphpからpostgresqlを使うために次のようなファイルもインストールする
> 必要があると
> かかれており、
> 
> php-pgsql-3.0.15_i18n_ja-0vl1.i386.rpm
> 
> これをインストールしようとすると、
> 
> postgresql-devel-6.5.3_jp-2.i386.rpmをあらかじめ追加インストー
> ル
> 必要があると、コメントがでます。

…エラーメッセージは『引用』しましょう。意味が分からないのなら勝手に解
釈してはいけません…。

また、PHP-3.0.15 には security hole があり、いまでは PHP-3.0.18 が出て
います。i18n 版も同様。(See: http://php.jpnnet.com/)

> このソフトはどういう機能を持っているのかご存じの方がいましたら
> 教えて欲しいのですが。

php など、外部のソフトから PostgreSQL の機能を使うときに必要になります。

悪いことはいいませんから、

「PHP4徹底攻略」
http://www2b.biglobe.ne.jp/~caco/php/

を買って熟読しましょう。いちいちここで質問するよりは解決が早いはず…。

…というか、vine-users ML よりは

http://www.sra.co.jp/people/t-ishii/PostgreSQL/

の方が適しているような気もしますが。その場合は

http://sv.onweb.to/~pgsql_jp/view.mpl?TGT=pgsql_jp&seq=19303

あたりの注意事項はよく読むと吉でしょう。
-- 
大森保英 / かずさのすけ。
http://www.geocities.com/SiliconValley/Program/1018/linux/

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: References: