[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:030088] Re:今度はi815(i815eでした)


おはようございます。(もう昼ですけど、、、)

中村さま
banditさま
ご返事ありがとうございます。

中村さま

ご指示どおり、X3.3.6の方は休止し、とりあえず、X4.0.1を先に始末します。

> 現在の /etc/X11/XF86Config がどうなっているか分かりませんが、
> Filesセクションのフォントパスで "unix/:-1" が最初になってる
> か確認してみてください。
> FontPath   "unix/:-1"
> FontPath    "/usr/X11R6/lib/X11/fonts/TrueType"

X3.3.6時のバックアップを取っておいたので、XF86Configをくらべました。
確かに上記2項ありませんでした。
X3.3.6アンインストール直後、X4.01をインストールし
フォントパスの一番最初に2項を追加しました。
その時は日本語出ました。
が、コンピュータを再起動したとたんまた元に戻りました。
その後、全く駄目になりました。
再起動するまでは、X3.3.6上のフォントが生きていたのでしょうか?
すみません。"unix/:-1"ってどう言う意味でしょうか?
そこに関連するファイルがあるのでしょうか?

その後、上記2項以外のFontPathを全部#しました。
そうしたら、エラーが出て止まりました。

Could not init font path element unix/:-1, removing from list !
could not open default font 'fixed'

今度は、XF86Config内のModuleを
Load "freeytype"を#し
Load "xxt"を追加しました。

またエラーが出ました。
Could not init font path element unix/:-1, removing from list !
Could not init font path element /usr/X11R6/lib/X11/fonts/TrueType, removing
from list !
could not open default font 'fixed'

何かリストが無いと言っております。
X3.3.6を消したときに何か消えたようですが、何処か分かりません。
多分、この辺りなのでしょう、、、

gnomeのフォント設定が、X3.3.6上のを選択しているものと勝手に判断して
/etc/gnome/gtkrc.jaを下記を参考にして眺めています。
http://www.on.ics.keio.ac.jp/~yasu/jp_gnome.html
うーむ、よく分かりません。
適当に変えてはいるのですが、何も変わらないのが寂しいです。
XF86Config上で、フォント設定がうまくいっていないのでココで触っても無駄の感じ
がします。
X3.3.6からX4.01に変えたときのHPでもあるかと思い探しているのですが
私の検索能力不足で、どんぷしゃのが見つかりません。

ご指導の程、よろしくお願いします。

結構、雑誌もあてにならない、、、
あー、奥が深い、、、、はまっている、、、、

banditさま
>  XFree86 4.0 と 4.01 ではフォントの幅の計算がおかしくなっていたのです
> が、4.02 では改善されたようです。(こういったことでしょうか?)

最初にXwindowを立ち上げるとネスケが出て、gnomeの説明が出ます。
ネスケ上では日本語出てましたけど、確かにフォント幅異常でした。
gnomeメニュー等は、ホントの文字化けです。
こちらも治るのでしょうか?

ありがとうございます。テストしてみます。

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: References: