[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:030255] IBM DB2 の話


かずさのすけです。
遅まきながらも Subject を変えました。

On Fri, Jan 05, 2001 at 08:09:39AM +0900,
Hideyuki MITA <cg3h-mt@asahi-net.or.jp> wrote:
> おはようございます、三田です。
> 
> PHP は最近は書かないんですが・・・。
> 
> Yasuhide OOMORI / 大森保英 <dasen@icntv.ne.jp> wrote:
> >
> > あ〜でも IBM DB2 対応な PHP4 DSO 版は、Vine-2.0 では動くものの
> > RedHat-6.2 では動かない (SIGTERM で瞬殺される) とか、あんまりよく分か
> > らない違いに悩まされることもないわけではない、ということだけは指摘させ
> > ていただきます :-)
> 
> え、ソースからコンパイルしてもですか?

そうなんです…。Vine-2.0 なら DSO 版でも動くようです。RedHat-6.2 の場
合、apache に静的に組み込まないと動かないようです。V6.1 での話なので、
最新の V7.1 の方でどうなのかまでは分からないのですが。

> それとも、DB2 対応の PHP4 はバイナリのみの配布とか?

あ、いや、PHP4 内に、IBM DB2 に対応させるコードが入っています。IBM DB2
から見れば、PHP4 は CLI application と見えるはずです。SDK はバイナリ配
布ですが…。

> > 本腰入れるにしても PHP はサポート外だろうなぁ(ぼそ)
> 
> ASP はどうなんでしょう?
> ASP をサポートしてくれるのなら、PHP もサポートして欲しいなぁ、なんて
> 気もしますね。(理由は、なんとなく、です ^^;)

Perl の DBI/DBD の方は、

ftp://ftp.software.ibm.com/ps/products/db2/info/vr7/db2a0j70.pdf

の p.739 以降に説明がありますね。ASP の方は分かりませんが、ADO のサン
プルなら同じ文書にありますね。

> # まぁ、Vine が完全に RedHat の upper-compatible ではない、というのは
> # あるんでしょうけれど、RDBMS みたいなものを使うのであれば、敢えて Vine
> # ではなくても良いかな、という気はするんですが。やはり Vine は Desktop
> # 用途を指向しているということで・・・。

RedHat の方が、『使える人が多い』というのはあるかもしれません。サーバ
機には RedHat (あるいは Turbo とか) を入れ、普段は Windows で作業する、
というスタイルの人も結構いるような気がしています。どうせ普段 Vine 使っ
ている人ならサーバ機が RedHat だったとしてもすぐに慣れるでしょうし…。
-- 
大森保英 / かずさのすけ。
http://www.geocities.com/SiliconValley/Program/1018/linux/

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
References: