[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:030265] Re: [vine-users:030043] Re: postgresql-6.5.3_jpの質問


渋谷@パッケージャです。

> > > > apache + postgresql + php をVine2.0で使おうと思っています。
> > > > 最初にpostgresql-6.5.3をインストールしようと思っているのですが、
> > > > 次のことが分かりません。
> > >
> > > 新規に入れるのなら、最近のバージョンでもいいような気がしますが…。
> > > たぶん一般的な手順としては /usr/local/pgsql あたりに入れるので、アンイ
> > > ンストールやアップグレードはそれほど困らないはず。
> >
> > あれれ、Vine には PostgreSQL の 7.0 がある筈ですが・・・?
>
> そうですね。
>
> ftp://ftp.jaist.ac.jp/pub/os/linux/Vine/VinePlus/2.0/RPMS/i386/postgre*
>
> を確認したところ、7.0 の rpm がありますね。

Vine 2.1 には 7.0.2 も入っていますので、SRPMS を rebuild すると方法も
あります。
手元には 7.0.3 も作っているので、専用線環境に接続できたときにでも
VinePlus あたりに上げたいと思います。


> > Apache と PostgreSQL は Vine デフォルトを使うとして、その上で PHP の
> > SRPM をリビルドしてインストールすれば良いんじゃないでしょうか?
>
> 『PHP3 と PHP4 のどちらを使うか』で、これまた悩んだりして (^^;
>
> たしか VinePlus の PHP4 の rpm には問題があったと聞いた記憶があります
> が…私はモジュール化するのが面倒だったのでモノシリックな (?) rpm を作っ
> てしまいました (^^;;;

Vine 2.1 だとおかしかったみたいです。私の環境でなぜ build できたのか
不明ですが。2.1 CR で rebuild すると確かにだめでした。
ということで 4.0.4 + i18n モジュールは作りました。
こちらも近々 Plus にあげたいと思います。
3.0.18-i18n も作ってあるんですが、RPMS の name が php で Plus に 3, 4 の
同居ができれば、アップします。
ホームページの方は早いうちに変更したいと思います。

後、PHP3, 4 の両方を使いたかったので、両方インストールできるようにした
(--enable-versioning をつけた) RPMS を作ったんですが、使いたい人って
結構いますか?

shibuya@alpha.or.jp

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
References: