[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:030537] Re: mozilla0.6 install


かずさのすけです。

On Fri, Jan 12, 2001 at 05:35:59AM +0900,
Koji Nakamura <hawks@da2.so-net.ne.jp> wrote:
> > 先日、VinePPC2.1にVineSeedPlusからmozilla0.6をrpmファイルでインストールして使っております。あまりに快適で、Communicator4.75も残してはいるものの、使っているのはもっぱらmozillaばかりです。
> > 
> > そこで、ThinkPAD390Xにもmozilla0.6を入れようと思い、VineSeedPlusからi386用rpmを持ってきてインストールしようとしたのですが、
> > 
> > [root@tp390x shunta]# rpm -ivh mozilla-0.6-0vl1.i386.rpm 
> > エラー: 依存性の欠如:
> >         libstdc++-libc6.1-2.so.3は mozilla-0.6-0vl1 に必要とされています
> > 
> > と出てしまい、インストールができません。
> > PPCの時は問題なくインストールできたので、「どうせ同じだろう」と
> > 考えていたのですが、、、。
> 
> 少なくともこの mozilla に関しては egcs-1.1.2 ではなく gcc-2.95.3
> でコンパイルされてるようなのでこういう問題が起こります。

しかも、素の gcc-2.95.2 附属の libstdc++ とは互換性がないようです。
undefined symbol が山のように出てきて起動できませんでした (ToT)

やはり rebuild するのがいちばん早いようです。ただし、ディスクの空き容
量が 250MB 程度しかないと食い潰されるので気をつけましょう (^^;;;
(See: http://www.mozilla.org/build/unix-details.html)

うちのマシンで rebuild したものは、私のホームページから辿れるようにし
てあるので、よろしければどうぞ…。

> # 今後も mozilla に限らずこういう問題は出てくると思いますが、
> # Vine の HomePage で「注意してください」ってアナウンスしてるのだ
> # から、自分で解決できない人は手を出さない方が吉だと思います。
> # なお、gcc-2.95.3 で何が変わったか(変わるのか)とかいう話題はここ
> # 向きの話題ではないので自分で調べてください。(できない人はそれこ
> # そ手を出さないように)

まぁ他の distribution のバイナリを何も考えずにインストールするとかいう
のは止めておいた方が幸せになれると思いますが、「手を出すな」というのは
言い過ぎなのではないでしょうか?
-- 
大森保英 / かずさのすけ。
http://www.geocities.com/SiliconValley/Program/1018/linux/
# rebuild 猿もまたよし < ぉ

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: References: