[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:030548] Re: mozilla0.6 install


中村@埼玉蕨市です。


Yasuhide OOMORI / 大森保英 <dasen@icntv.ne.jp> wrote:

> > # 今後も mozilla に限らずこういう問題は出てくると思いますが、
> > # Vine の HomePage で「注意してください」ってアナウンスしてるのだ
> > # から、自分で解決できない人は手を出さない方が吉だと思います。
> > # なお、gcc-2.95.3 で何が変わったか(変わるのか)とかいう話題はここ
> > # 向きの話題ではないので自分で調べてください。(できない人はそれこ
> > # そ手を出さないように)
> 
> まぁ他の distribution のバイナリを何も考えずにインストールするとかいう
> のは止めておいた方が幸せになれると思いますが、「手を出すな」というのは
> 言い過ぎなのではないでしょうか?

まぁ、確かに言いすぎと言われても仕方ないし、それについては
何も言う事はありません。

ただ、この件については本人が自覚しているかしていないかは別
として、リスクを侵すのであれば最低限「依存関係の問題で何の
パッケージが要求されてるのか」を確認するのは当り前のことだ
と思いますし、それを確認するのは技術的に難しいことではない
でしょう。

それと、松本さんも少し触れられてますが、私自身 gcc-2.95.3
で年末ぐらいから更新されたパッケージを rebuild してみました
が、

  * コンパイルエラーで rebuild できない
  * root では rebuild できるが一般ユーザーだと rebuild できない

パッケージがいくつかありました(簡単に原因を調べられそうに
なかったので中断して、そのときのリストも破棄してしまいま
したが)。

なので、単純に gcc & libstdc++ をインストールして、実行環
境を作るだけならまだしも、パッケージを build する可能性ま
で考えた場合、スキルの低い人がパニックになるのは目に見え
てるので、冗談抜きに人に勧められることではないんです。

# それ以外にも、最近のパッケージってマクロを結構使用してる
# ので、「rebuild してね」って言うだけでは不十分で、
# 「~/.rpmmacros にこう書いてね」までフォローしないと余計
# 混乱しそうな気がするのは私だけ?


----
中村  幸治 <hawks@da2.so-net.ne.jp>

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: References: