[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:040544] Re: [vine-users:040542] Re: libbz2.so.0をインストールするには?


稲垣さんありがとうございますが、
もうその過去ログは見て、必要なRPMを同時に書いて
インストールを試みましたがダメでした。
最終的目標:rpm3.0.3 -> rpm-3.0.6 にアップデートしたい!
rpm-3.0.6-0vl2.src.rpm をリビルドする際に、
bzip2 >= 1.0.0 が必要
popt >= 1.5 が必要
と怒られる!
そこで、
bzip2-1.0.0-1.i386.rpm
popt-1.5.1-0vl2.i386.rpm
をインストールしようとすると、
libbz2.so.0 が必要だと怒られます。

そこで、libbz2.so.0をインストールするにはどうしたらいいのか
知りたいです。
しかし、/usr/lib/ にlibbz2.so はシンボリックリンクであるんです。
調べたところ、libbz2.so.0 がrpmでインストールされていないから
rpmの管理下にない為、libbz2.so.0が必要だよと怒られている?
みたいなのですが、そのlibbz2.so.0をrpmの管理下にするにはどの
ようにしたらよいかもわかりません。
長くなりましたが、お知恵をお借りしたいと思います。お願いします。

>>稲垣です。
>>
>>過去ログで似たような問題を扱っているので、
>>参考にしてみてはいかがでしょうか。
>>
>>[vine-users:027793] [Q] installing gnorpm
>>http://search.luky.org/vine-users.2/msg07717.html
>>"Toshiaki Ishihara" <toshiaki_i@po.dainana.co.jp> wrote:
> 石原と申します。
>
> libbz2.so.0 をRPMのパッケージでインストールするには
> どのRPMをインストールすればよいのでしょうか?
>
> rpm -Uvh bzip2-1.0.0-1.i386.rpm
>
> libbz2.so.0 が ImageMagick-4.2.9-1 に必要です
> libbz2.so.0 が gnorpm-0.9-10vl16 に必要です
> libbz2.so.0 が rpm-3.0.3-2vl6 に必要です
> libbz2.so.0 が rpmfind-1.2-4 に必要です
>
> と怒られまして、どうすればよいのかわかりません。
>
> 解かる方いらっしゃったら教えて下さい。
> よろしくお願いいたします。

--
Ryoichi☆Inagaki <ryo1@bc.wakwak.com>
http://www.ryo1.net/ (開店休業中)

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: References: