[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:040633] Re: errata of openssh


ジャック飯田です。

岩井さん、ありがとうございました。
早速、アップデートを試みました。


にしい@Project Vine さんの
> アップデート方法
>   rpm -Fvh openssh openssh-clients openssh-server \
>            openssh-askpass openssh-askpass-gnome
> or
>   apt-get update && apt-get install openssh openssh-clients \
>     openssh-server openssh-askpass openssh-askpass-gnome
>
> 注意事項
>   特に無し
>

を参考に、rpmファイルをゲットしてきて、

#  rpm -Fvh openssh openssh-clients openssh-server \
            openssh-askpass openssh-askpass-gnome

とやったら、

エラー: ファイル openssh をオープンできません: そのようなファイルやディレク
トリ
はありません
エラー: ファイル openssh-clients をオープンできません: そのようなファイルや
ディ
レクトリはありません
エラー: ファイル openssh-server をオープンできません: そのようなファイルや
ディレ
クトリはありません
エラー: ファイル openssh-askpass をオープンできません: そのようなファイルや
ディ
レクトリはありません
エラー: ファイル openssh-askpass-gnome をオープンできません: そのようなファ
イル
やディレクトリはありません

となってしまいました。

# apt-get update && apt-get install openssh openssh-clients \
     openssh-server openssh-askpass openssh-askpass-gnome

とやったら、

取得:1 http://vinelinux.org aptdata/i386/ パッケージ情報.0 [62.6kB]
無視 http://vinelinux.org aptdata/i386 リリース情報.0
取得:2 http://vinelinux.org aptdata/i386/ ソース情報.0 [19.2kB]
無視 http://vinelinux.org aptdata/i386 リリース情報.0
取得完了: 81.8kB を 1s で取得しました(66.8kB/秒)
ファイル依存を解決しています... 完了
パッケージリストを読みこんでいます... 完了
依存情報ツリーを作成しています... 完了
W: http://vinelinux.org/Vine-2.1-updates/ は認証されていません。
W: http://vinelinux.org/Vine-2.1-updates/ は認証されていません。
パッケージリストを読みこんでいます... 完了
依存情報ツリーを作成しています... 完了
You might want to run `apt-get -f install' to correct these:
以下のパッケージの依存関係を解消することができませんでした:
  postgresql-devel: Depends: postgresql (= 7.0.3) インストールすることができ
ませ
ん
E: 未解決の依存情報です。'apt-get -f install' を実行してみてください(又は解
決パ
ッケージを明示してください)。

と言われてしまいました。なぜ、opensshを指定しているのに、postgresql関係の
エラー(らしきもの)が出ているのでしょうか?
postgreSQLは、Vine標準のパッケージを削除して、手動コンパイル&インスト
ールしましたので、何らかのエラーはでてもおかしくないとは思うのですが、
openSHHの更新に成功したのかどうか、このメッセージではよくわかりません。

また、つぎのようなこともしてみました。
# rpm -Uvh openssh-2.9.9p2-0vl0.3.i386.rpm
エラー: 依存性の欠如:
        openssh = 2.5.1p2-0vl1は openssh-askpass-2.5.1p2-0vl1 に必要とされて
いま
す
        openssh = 2.5.1p2-0vl1は openssh-askpass-gnome-2.5.1p2-0vl1 に必要と
され
ています
        openssh = 2.5.1p2-0vl1は openssh-clients-2.5.1p2-0vl1 に必要とされて
いま
す
        openssh = 2.5.1p2-0vl1は openssh-server-2.5.1p2-0vl1 に必要とされて
いま
す

これはアップデートするパッケージの順番が悪いということでしょうか?そうだと
すれば、正しい順番はどうすればわかるのでしょうか?


なお、現在のrpm情報を見たら、このようになっていました。
# rpm -qa | grep openssh
openssh-2.5.1p2-0vl1
openssh-askpass-2.5.1p2-0vl1
openssh-askpass-gnome-2.5.1p2-0vl1
openssh-clients-2.5.1p2-0vl1
openssh-server-2.5.1p2-0vl1

コンパイルが当たり前のSlackware村からVine村へ引っ越してきてまだ日
が浅く、RPMの仕組みがよくわかっておりません。
apacheのアップデートでは、RPMの威力に感動したものですが、一旦躓くと
手動コンパイル&インストールのほうが簡単ですね。でも、将来的に考え
ると、パッケージ管理を捨てるわけにもいかず、どうしたものか困っています。

どうしたら、openSSHパッケージをアップデートできるのでしょうか?
「標準RedHat Linuxリファレンス」のRPMに関する説明は読んだのですが、
解決できませんでした。
詳しい方、解決法をご教授ください。

----
n.IIDA
zad61103@rose.zero.ad.jp

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: References: