[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:040634] Re: errata of openssh


>> "IIDA" == n IIDA <zad61103@rose.zero.ad.jp> writes:

IIDA> にしい@Project Vine さんの
>> アップデート方法
>> rpm -Fvh openssh openssh-clients openssh-server \
>> openssh-askpass openssh-askpass-gnome

あう、パッケージ名じゃなくてファイル名で指定する必要がありますね。

rpm -Fvh openssh-2.9.9p2-0vl0.3.i386.rpm \
	 openssh-clients-2.9.9p2-0vl0.3.i386.rpm \
	 (以下略)

という感じで。

IIDA> 以下のパッケージの依存関係を解消することができませんでした:
IIDA>   postgresql-devel: Depends: postgresql (= 7.0.3) インストールすることができ

あれ?  postgresql が入っていないのに postgresql-devel が
入っていたりしますか?

IIDA> openSHHの更新に成功したのかどうか、このメッセージではよくわかりません。

更新をするときは rpm を実行するというメッセージと rpm の
出力する #####.... が出ますので、わかると思います。
このエラーは rpm を実行する前に起きているということですね。

IIDA> また、つぎのようなこともしてみました。
IIDA> # rpm -Uvh openssh-2.9.9p2-0vl0.3.i386.rpm
IIDA> エラー: 依存性の欠如:
IIDA>         openssh = 2.5.1p2-0vl1は openssh-askpass-2.5.1p2-0vl1 に必要とされて

openssh-* のサブパッケージは openssh の同じバージョンに
依存しているので、全部同時に更新する必要があります。
つまり、最初に書いたように、1回の rpm コマンドで
全部を指定するということです。

IIDA> コンパイルが当たり前のSlackware村からVine村へ引っ越してきてまだ日
IIDA> が浅く、RPMの仕組みがよくわかっておりません。
IIDA> apacheのアップデートでは、RPMの威力に感動したものですが、一旦躓くと
IIDA> 手動コンパイル&インストールのほうが簡単ですね。でも、将来的に考え
IIDA> ると、パッケージ管理を捨てるわけにもいかず、どうしたものか困っています。

何度かやってると慣れてくると思います。

-- 
西村 大介 <nishi@graco.c.u-tokyo.ac.jp>
東京大学 総合文化研究科 広域システム科学系

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: References: