[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:050310] Re: Vine 2.5 でw3mが起動できない


自己レスです。なんとか解決しました。

Vine2.1.5 の cdrom にある w3m-0.1.10-0vl5.i386.rpm に
ダウングレイドしてみようとしたら

# rpm -U --oldpackage w3m-0.1.10-0vl5.i386.rpm
エラー: 依存性の欠如:
        libcrypto.so.0は w3m-0.1.10-0vl5 に必要とされています
        libssl.so.0は w3m-0.1.10-0vl5 に必要とされています
        w3m >= 0.3は w3m-el-1.2.6-0vl1 に必要とされています

といわれたので調べたところ
openssl,opessl-devel ともにインストールしているのに
libcrypto.so.0、libssl.so.0 ともにありませんでした。

そこで以下のようにリンクを張ったところ
# ln -s /lib/libssl.so.0.9.6b /lib/libssl.so.0
# ln -s /usr/lib/libcrypto.so /usr/lib/libcrypto.so.0

めでたく起動するようになりました。
正しい解決方法かどうかはわかりませんが、とりあえず
OKのようです。

お騒がせしました。

(でも、この依存関係は $ apt-cache depends w3m では
出てこないのですがどうしてなのでしょうかね。
apt-cache で出てくる依存関係は一応、チェックしていたのですが)

----
森島 香二
kojim@kf.catv.ne.jp

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
References: