[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:060532] Re: Lucent用ドライバのインストールについて


長南です。

よい機会なので、私も ltmodem-8.26a9.tar.gz を入れてみました。
例によって、build_rpm でも rpm -ivh でも、あやしげなメッセージが
出ましたが、問題なく使えているようです。マシンは ThinkPad i1800、
モデムは Xircom MPCI + Modem 56 WinGlobal とかいうもの。
Vine は 2.6。kernel は 2.4.19-0vl26。

富永さんの場合、ltmodem ドライバがモデムに対応していないのか、
ドライバ(rpm パッケージ)の作成・インストールに失敗しているのか、
それとも、PPxP の設定の問題なのか、切り分ける必要があると思います。

冨永さんのメールより [vine-users:060510]
> 
>  ltmodem-8.26a9.tar.gzを無事インストールすることができました。しか
> し、なぜかモデムを認識してくれません。
> 
> 調べていないのでなんともいえませんが、もともとサポートされていない
> のかもしれません。動作実績リストなどが掲載されているWebサイトなど
> で調べてみたいと思います。

Web で調べるのはよいことですが、ltmodem-8.26a9.tar.gz に含まれている
scanmodem は実行してみましたか。それで、自分のモデムがサポートされて
いるかどうか、一応わかると思います(詳しくは、ltmodemm-8.26a9/1ST-READ
をお読みください。ltmodemm-8.26a9/DOCs にもいろいろ文書があります)。

  # cd ltmodemm-8.26a9
  # ./scanmodem

それから、「無事インストールできた……モデムを認識してくれない」との
ことですが、それぞれどうやって判断しましたか。

たとえば――
uucp パッケージはインストールしてありますか。rpm -q uucp で
調べてください。もしインストールしていなかったら、uucp
パッケージを VinePlus からもらって来て、インストール。
それから、以下のようにします。

  $ cu -l /dev/ttyLT0
  Connected.
  AT             # AT と打ち込む
  OK
  ~[hoge].       # ~ をタイプし、[ホスト名]が出たら、ピリオドで終了

  Disconnected.

AT と打ち込み、OK と返ってきたら、モデムとの通信に成功しています。

もし、これがうまく行かないようなら、モデムがサポートされていないか、
ドライバの作成・インストールに失敗した可能性が高いと思います。
うまく行くようなら、おそらく PPxP の設定の問題です。

-- 
長南洋一
cyoichi@maple.ocn.ne.jp

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: References: