[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:060600] Re: battery_applet for ACPI (gnome-applet 1.4)


林です。

From: Tomohito MAKINO <tomohito@ueda.info.waseda.ac.jp>
Date: Wed, 21 May 2003 01:54:58 +0900

> gnome 1.4のバッテリモニタアプレットをACPIに対応させるパッチを
> http://drocklinux.dyndns.org/rene/acpi-applet/index.html
> で頂いたのですが、マシンが違うせいなのかカーネルのバージョンが違うせいなのか
> あるいは両方なのか、そのままではうまく動きませんでした。
> 
> でも、ちょっと手を加えたら動いたのでここに置いておきます。
> http://www.ueda.info.waseda.ac.jp/~tomohito/software/gnome-applets-1.4.0.4-acpi2.4.20/

VineLinux2,6r1 の方はみなさんうまく行っているようですが、
VineLinux2.5 なせいか、私の VAIO PCG-SRX7F/P ではうまく行きません。

どうも scrollkeeper-config が必要だけれどもみつからない、ということのようですが、
VineLinux2.6r1 にはこの scrllkeeper-config がどこかに存在しているのですよね?
どの rpm に入っているものなのでしょう? (VineLinux2.5 でもそれを入れれ
ば動くのでしょうか)

| $ cat /etc/vine-release 
| Vine Linux 2.5 (Domaine de Chevalier)
| $ uname -sr
| Linux 2.4.20-0vl29.1
| $ (cd ftp/; wget http://www.ueda.info.waseda.ac.jp/~tomohito/software/gnome-applets-1.4.0.4-acpi2.4.20/gnome-applets-1.4.0.4-acpi2.4.20.patch)
...
| $ rpm -q gnome-applets
| gnome-applets-1.4.0.4-0vl1
...
| $ (cd ftp; wget ftp://ftp.jaist.ac.jp/pub/os/linux/Vine/Vine-2.5/SRPMS/SRPMS/gnome-applets-1.4.0.4-0vl1.src.rpm ftp://ftp.jaist.ac.jp/pub/os/linux/Vine/Vine-2.5/i386/Vine/RPMS/gnome-applets-1.4.0.4-0vl1.i386.rpm)
...
| $ (cd rpm/SOURCES/; rpm2cpio ~/ftp/gnome-applets-1.4.0.4-0vl1.src.rpm |cpio -iv)
| gnome-applets-1.1.5-gnote_fix.patch
| gnome-applets-1.1.5-pppcmd.patch
| gnome-applets-1.4.0.4.tar.bz2
| gnome-applets-vl.spec
| 10061 blocks
| $ mv -i rpm/SOURCES/gnome-applets-vl.spec rpm/SPECS/
| $ diff -u rpm/SPECS/gnome-applets-vl.spec{~,}
| --- rpm/SPECS/gnome-applets-vl.spec~	Thu May 22 00:49:18 2003
| +++ rpm/SPECS/gnome-applets-vl.spec	Thu May 22 00:55:19 2003
| @@ -1,6 +1,7 @@
|  %define name	gnome-applets
|  %define ver	1.4.0.4
| -%define rel	0vl1
| +#%define rel	0vl1
| +%define rel	0vl1.1
|  
|  Summary:	Small applications which embed themselves in the GNOME panel
|  Summary(ja):	GNOMEパネルに組み込まれるちいさなアプリケーション
| @@ -20,6 +21,7 @@
|  Source: 	ftp://ftp.gnome.org/pub/GNOME/unstable/sources/%{name}/%{name}-%{ver}.tar.bz2
|  Patch1: 	gnome-applets-1.1.5-gnote_fix.patch
|  Patch3: 	gnome-applets-1.1.5-pppcmd.patch
| +Patch4: 	http://www.ueda.info.waseda.ac.jp/~tomohito/software/gnome-applets-1.4.0.4-acpi2.4.20/gnome-applets-1.4.0.4-acpi2.4.20.patch
|  
|  
|  %description
| @@ -47,6 +49,7 @@
|  %setup -q
|  %patch1 -p1 -b .gnote_fix
|  %patch3 -p1 -b .pppcmd
| +%patch4 -p1 -b .acpi
|  
|  
|  %build
| @@ -158,6 +161,9 @@
|  
|  
|  %changelog
| +* Thu May 22 2003 HAYASHI Chifumi <chifumi@mscom.or.jp> 1.4.0.4-0vl1.1
| +- add acpi patch.
| +
|  * Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.4.0.4-0vl1
|  - New upstream release.
|  
| $ rpm -ba rpm/SPECS/gnome-applets-vl.spec
| 実行中(%prep): /bin/sh -e /var/tmp/rpm-tmp.98840
...
| + echo 'Patch #4 (gnome-applets-1.4.0.4-acpi2.4.20.patch):'
| Patch #4 (gnome-applets-1.4.0.4-acpi2.4.20.patch):
| + patch -p1 -b --suffix .acpi -s
| + exit 0
| 実行中(%build): /bin/sh -e /var/tmp/rpm-tmp.28138
| + umask 022
| + cd /home/chifumi/rpm/BUILD
| + cd gnome-applets-1.4.0.4
| + CFLAGS=-O2 -m486 -fno-strength-reduce
| + export CFLAGS
| + CXXFLAGS=-O2 -m486 -fno-strength-reduce
| + export CXXFLAGS
| + FFLAGS=-O2 -m486 -fno-strength-reduce
| + export FFLAGS
| + '[' -f configure.in ']'
| + libtoolize --copy --force
| You should update your `aclocal.m4' by running aclocal.
| + ./configure i386-vine-linux --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib --libexecdir=/usr/libexec --localstatedir=/var/lib --sharedstatedir=/usr/share --mandir=/usr/share/man --infodir=/usr/info
| creating cache ./config.cache
| checking for a BSD compatible install... /usr/bin/install -c
...
| creating libtool
| checking what warning flags to pass to the C compiler... -Wall -Wunused
| checking what language compliance flags to pass to the C compiler... 
| checking for pthread_create in -lpthread... yes
| checking for gtk-config... /usr/bin/gtk-config
| checking for GTK - version >= 1.2.0... yes
| checking for SmcSaveYourselfDone in -lSM... yes
| checking for X11/SM/SMlib.h... yes
| checking for XpmFreeXpmImage in -lXpm... yes
| checking for scrollkeeper-config... no
| configure: error: Couldn't find scrollkeeper-config
| /var/tmp/rpm-tmp.28138 の不正な終了ステータス (%build)
| $ locate scrollkeeper
| $ 

configure 直前に
| You should update your `aclocal.m4' by running aclocal.
と出ているので、configure 直前で aclocal を動かすと、今度は↓です。

| + aclocal
| aclocal: configure.in: 9: macro `AM_ACLOCAL_INCLUDE' not found in library
| aclocal: configure.in: 220: macro `AM_GNOME_GETTEXT' not found in library
| /var/tmp/rpm-tmp.37588 の不正な終了ステータス (%build)
-- 
 林 千史  chifumi@mscom.or.jp

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: References: